I.T. Mate
                      Product Support
Menu: Home | Blog | Contact Us | Documents | Forums | Knowledge Base | Search | Services RSS

.... NEVER FORGET! ....
Quick Search
 

Products
AB Extension Pack
ACF Notes
ActiveScan Cleaner
B Gone
Bit Defender Cleaner
Black Jack
Chess
Cookie Info
Cup Holder
Dir 2 File
DUN AC
FreeScan Cleaner
Guestbook Generator
Housecall Cleaner
hpHosts
hpObserver
Index.dat QV
Index.dat Suite
ISPs Nightmare
Mouse Mat
Outlook Export
PUI
Quick Info
Quick Ren
RF Types
Rip Wiz 2003
S Lock
SMTP Finder
Spambot Search Tool
vURL Desktop Edition
Home > Products > Index.dat Suite

Index.dat Suite

  1. Overview
  2. Download
  1. FAQ
  2. How To's
  1. Screenshot
  2. System Requirements
How To's
Setting up Index.dat Suite
Get to a command prompt in Windows 2K, XP, Server 2003
Deleting the index.dat files manually
Using the .bat file manually
Using Index.dat Suite


Setting up Index.dat Suite
To setup Index.dat Suite;

1. Load Index.dat Suite and click Tools > Settings (Shortcut: F11)
2. On the General tab;

a. Tick "Mark items in red that may not be safe to delete"
b. Tick "Always verify batch file contents after file generation"

3. On the Batch File tab;

a. Tick "Add file to RunOnce registry key after file generation"
b. Tick "Show generated batch file"
c. UNTICK "Use default file generation routine to remove all index.dat files"

4. On the Folders tab;

a. Tick Cookies, History, Prefetch, Recent Documents, Temporary Internet Files, Temp Files

If you want Defrag to be ran aswell (reccomended), click the Misc tab and tick "Run defrag after index.dat file deletion"

Now click Save to close the Settings dialog.

Index.dat Suite is now ready to be run.

Get to a command prompt in Windows 2K, XP, Server 2003
Note: The following only applies if you intend running the generated batch file MANUALLY. Otherwise, we suggest using the RunOnce registry key option in the Index.dat Suite settings as this allows you to simply generate the file, and re-start your computer.

If you cannot get to a command prompt using the normal methods, including using a Windows 2K boot disk, you can use an earlier boot disk to do so.

Download the 98SE boot disk and extract the files onto a floppy diskette.

Re-boot your computer with the boot disk inserted.

Deleting the index.dat files manually
Note: The following only applies if you intend running the generated batch file MANUALLY. Otherwise, we suggest using the RunOnce registry key option in the Index.dat Suite settings as this allows you to simply generate the file, and re-start your computer.

To delete the index.dat files, run Index.dat Suite and click Find to allow it to locate the files.

Once it has found the files, click the "Generate File" button on the toolbar, this will generate the .bat (batch) file for you.

It is easier to use if you save the file in the root folder (i.e. c:\file.bat).

Once the file is generated, it is then shown to you so you may check for any errors, or add any extra commands to it.

To use the file, re-boot into MS-Dos mode.

To get to MS-Dos mode, re-start your computer and either insert your Windows boot disk, or press F8 when it says "starting windows".

If pressing F8, select "Command Prompt Only".

Once at the command prompt, you will be presented with something looking like this;

C:\>

Type: run.bat (where 'run' is the filename), and press enter.

Using the .bat file manually
Index.dat Suite v2.3.x and above now allows the .bat file to be run automatically via the registry's RunOnce key, as such, the below applies to Index.dat Suite v2.2.x or below only.

To use the .bat file, boot into DOS mode using the procedure below.

Windows 95, 98, 98se, ME

1. Go to Start
2. Select Shutdown
3. If available, select "Re-start in MS-DOS Mode"

Windows NT, 2000 (2K), XP, 2003

Users of the above operating systems will need a boot disk. These can be obtained from www.bootdisk.com.

Once you have obtained the boot disk, use it to get to a Command Prompt.

4. At the prompt, type: a:\run.bat (replacing a with the drive letter, and run with your chosen filename).

Using Index.dat Suite
The following is a brief overview on using Index.dat Suite to delete and/or view the index.dat files. This document assumes you are using Index.dat Suite version 2.7.x (upto 2.7.2).

Viewing the index.dat files

Index.dat Suite has been coded to allow you to view the index.dat files using either the internal viewer, or an external viewer of your choosing. To view the files with the internal viewer, simply click the Find button and wait for the scan to finish. Once the scan is complete, you can simply select the file you wish to view, and either click the "View File Contents" button on the toolbar, or right click the file and select "View File Contents".

Once you have clicked to scan the files, you will see a prompt that warns you the scan may take a while. The prompt can be disabled in the Index.dat Suite settings for those that do not wish to see it, however, please note, the scan may take upto and over 30 minutes, depending on the size of the file and the speed of your computer.

Once the scan of the file is complete, you will be told how many items were found. You can save these results to a file by right clicking the list and selecting the appropriate option.

Deleting the index.dat files

Index.dat Suite's primary function is to allow you to delete the files that cannot be deleted via Windows. It does this by generating a batch file that is run the next time you re-boot (re-start) your computer. If you DO NOT wish to run the file manually in DOS, we suggest enabling the option labelled "Add file to RunOnce registry key after file generation" in the Index.dat Suite settings (Tools > Settings > Batch File (tab)).

As with viewing the index.dat files, you start this process by clicking the Find button on the main IDFinder window (the default window that is shown when starting the program), and waiting for the scan to finish. Once the scan is complete, you can simply click the Batch File Generation button on the toolbar, and re-start your computer (the rest will be done for you).

Generating a new file automatically

This option was added in version 2.7.0 to allow you to click a button and have everything done for you automatically (from the scan of your system, to the batch file generation).

To have a new file generated each time you start your computer, simply create a shortcut with the following properties in your Start-up folder.

Shortcut Name: Index.dat Suite (Automatic)
Target: "PATH_TO_IDS\IDSuite.exe" /auto

Where PATH_TO_IDS\ is the path to the Index.dat Suite program folder (e.g. C:\Program Files\Index.dat Suite\).

When using this option, you will see the following dialog display. This simply tells you what it is doing. Once finished, you will be shown the batch file just as you would normally.

Index.dat Suite - IDS Auto


Give us Feedback! Forums
End User Licence Agreement | Help Us | Privacy Policy | Terms of Use
Copyright 1998 - 2017 I.T. Mate - All Rights Reserved
counselling-valvate
counselling-valvate
counselling-valvate
counselling-valvate
Give us Feedback! Forums